Delayed settlements for Bambora Acquiring transactions

Incident Report for Dintero

Resolved

The settlements arrived as normal and will be paid out as normal
Posted Jun 22, 2026 - 21:04 UTC

Identified

We would like to inform you about a third party technical issue affecting settlements scheduled for the 2026-06-22. This affects payments executed with Bambora Acquiring.
Posted Jun 22, 2026 - 13:42 UTC
This incident affected: Checkout & Payments (Payout).