Swedbank Pay card processing issues
Incident Report for Dintero
Resolved
This incident has been resolved.
Posted Jun 14, 2024 - 12:21 UTC
Investigating
Swedbank Pay are having issues with card processing, and intermittent issues with Vipps and MobilePay.

More details about the incident on Swedbank Pay's status site at https://status.swedbankpay.com/incidents/26tsncc6ygy9
Posted Jun 14, 2024 - 10:20 UTC
This incident affected: Checkout & Payments (Checkout).